Yes, someone actually did this and I found it running on our server
You want to expand your business to Europe. Bam, your code is broken, in Europe the week starts on Monday.
Than you want to expand to the middle east. Bam, broken again… Because in arab countries and Israel, the weekend is on Friday and Saturday.
Then you want to expand to Mexico and India. Bam, broken again, their weekend is only on Sunday.
The obvious solution is to inject an IWeekendDaysOfWeekProvider service in the inversion of control container. In your, uh, javascript web app.
Just npm install isWeekend for the required locales.
Depends on: isMonday, isTuesday,…
…isWednesdayMyDudes…
This dude(ette) globalizes.
Not using
CultureInfo.InvariantCulture
for basically everythingI was wondering why the second example returned monday and tuesday. I had no idea the week could start any day other than monday
Honestly the first one is the only one that works when people define the first day of the week differently. On the other hand, it does make you wonder. If Sunday is the first day of the week (as it is in many places) then how is it also part of the weekend?
But if you’re worried about locale, you can’t assume people use the string “Saturday” to describe Saturday either. That solution only works in English.
I assume this is in a language where the first day of the week is a fixed part of the language (like JS).
Yeah it’s the front end of the week and Saturday is the rear end
They’re the week’s ends, front and back.
Thats not really one weekend then though, is it? Its more like last week’s post-week weekend and this week’s pre-week weekend
Ok another US local units are retarded rant: it’s called weekEND! why do you start your week at sunday and not monday! Sunday is part of the weekEND!
If you’re referring to an “end” of an object, it can refer to the extreme of a side of it. For example, aglets are at either end of a shoelace.
I’m refering to end in a temporal sense because we are talking about a time context here. There is a clear direction so going backwards brings you to the start.
Why would you call it weekend and the start the week with half of it?!
A rope has two ends, and so does a week
Sentences have both meanings and sound, yours have sound
I like fancy insults
Methinks your username is a little too relevant right now :p
Do you say weekend or weekends?
So, where does it start then?
At the ends
Three-day workweek now
weekend = day_of_week in (“sat”, “sun”)
As a bonus this completely sidesteps the issue of what day is 0 or 1.
Until some idiot sends in “Sunday” as days of the week…
yeah I like having an array of days that are weekend days then testing if the day is in the array. can change what days are considered weekend if we go to a three day weekend and it reads really well. I hate massive if statements
You forgot weekend = dayOfWeek.name[0] == ‘S’;
I’d make it a named function for clarity and testability and proceed to give zero shits how it is implemented. I would unironically write this code if it worked, but I wouldn’t inline it to reduce the cognitive load of reading it.
This, and maybe a couple of unit tests
weekend = dayOfWeek > 5
dayOfWeek is clearly represented by 1-7 in the example, with Sunday being 1.
So, I guess the answer is “depends on what date library you’re linking against”
Sunday is
10 and Saturday is76.You just made Friday part of the weekendYou forgot SundayOn which planet? Monday is 1
Both Monday and Sunday are used as the first day of the week with quite some regularity. It’s a completely arbitrary standard no different to "the tenth month is the one called “October”. Or dividing a day into 24 segments which are each broken into 60 smaller segments of 60 even smaller segments. You can’t say either is “wrong” per se.
Personally, I was brought up learning Sunday is the first day of the week, but at some point decided that was bullshit partly because it’s the week end. But also just from a practical standpoint when looking at a calendar, it’s useful to have the weekend days grouped together.
Funny thing, september comes from the number 7, october from 8 and november and december from 9 and 10, as the year in ancient rome was starting around march. This problem is timeless.
Huh. I knew about the problem (that’s why I used October as my example, rather than, say, February), but I was mistaken as to the cause. The way I had always heard it told, September–December don’t match their current place in the year because of the addition of July and August. But I just looked it up and it seems you’re right. Those months are merely renamings of Quintilis and Sextilis, and the numbering issue comes from moving the start of the year from March to January.
Phew luckily my random memory was correct this time!
Yeah, that’s why my calendar starts the week on Saturday
On planet America.
Ah the same place that uses feet and inches, and puts the month before the day, and cannot read a 24 hour clock?
I was off by one, but Sunday is 0 in javascript
JavaScript is wrong
That’s nice, you can run
weekend = dayOfWeek > 5
and then explain to the boss why clients are getting work texts on a sundayDon’t use JavaScript on the backend ¯\_(ツ)_/¯
I’ll be sure to tell my boss to throw away all the work he already paid for and start over in a different language. I’m sure he’ll be very understanding
Yo nodejs is just plain amazing. We should just keep improving on js and replace all other languages. Js is already on all browsers, by adopting it on the server you get huge efficiency as you can move code AND coders between backend and frontend. Of course you must make the right choices of practices and frameworks for this to be possible
That’s nice, you can run
weekend = dayOfWeek > 5
and then explain to the boss why clients are getting work emails on a sunday
Cron has clearly the superior numbering system, where sunday is both 0 and 7
Depending on how you’re counting your integers, Monday is 0, being the first day of the week.
Interesting that your days are 1-indexed. What happens on nullday?
Reserved for future use
Undefined
Image Transcription: Meme
[Paneled meme with a brain that gets increasingly glowing]
[The brain is smaller than the skull]
if dayOfWeek.name == "Sunday" || dayOfWeek.name == "Saturday" weekend = true
[The brain is glowing in some areas]
if dayOfWeek < 2 || dayOfWeek > 6 weekend = true
[The brain is shooting out rays of light]
weekend = !((dayOfWeek - 1) % 6)
I am a human volunteer who transcribes posts to improve accessibility on programming.dev and you could be one too! !transcribing@programming.dev
Depending on whether this code is in a hotpath (and considering how “elementary” it is, I figure that’s a possibility), this could very well be a significant speed improvement.
Though I’d say that only excuses it if it’s truly an elementary function (and not one line as part of a larger function), as otherwise it’s unreadable garbage. But on its own it:
- has a clear purpose
- (presumably) isn’t reimplementing functionality
- is easily tested
- can be modified with no side effects (besides breaking your calendar, but that’s beside the point)
It’s one line as part of a larger function. Also, it doesn’t actually say
weekend
, it just executes some other functionalityif !(day % 6)
. I made it more readable so that everyone here could understand what it does